Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Release of 4.8.0.0-9165
#1
https://cp.sync.com/dl/cd6ca2010#q92cpba...g-4xnvbz2q

The recent soul searching has paid off. I truly believe the driver is fixed for the AP stall condition and I have some other ideas to improve stability and performance.

This new release has all of the old features that people have come to expect. Licensed frequencies, 5 & 10 MHz channel widths AND sync now works again. The site survey has issues and mostly does not work, but is being investigated.

I have done some brutal testing. The AP is a Ventana. I have a war1b client and an APU client. Each client is running a bidirectional iperf test (simultaneous rx and tx), in a 10 MHz channel in the 2.4 GHz band. The tests have run for 16 hours and show no indication of problems whereas at the start I was seeing a 10 minute lockup using 10 MHz. Eventually this reached 3 hours and then I recoded some driver parts and it now runs for 16+ hours.

This new firmware "might" still show some issue later, to be discovered, but for now I consider it to be the best available firmware and would ask people to give it a test on some troublesome sites and report back to me.

I apologize for the trouble, but I had been working very hard doing what I thought was correct. That is now behind me, and I hope to gain your trust back.

This new release is considered very complete except for the site survey. Unfortunately the APU and other platforms have not been built for this release. Each one will take about 2 days of work and testing to update the kernel and the driver, so please be patient and test what I have done so far.
Reply
#2
I have been able to get the APU firmware built. Rather than have a variety of version numbers I rebuilt the Ventana, War1B and APU and they are available for download using the same link as posted above.
Reply
#3
Sadly, I just can't win.

The test had been running on the units, at a 10 MHz channel, for nearly 16 hours, with no issues. So, I stopped the test and changed to a 20 MHz channel and it failed after about 1.5 hours to 4 hours. The interesting thing is that both clients did not get booted at the same time, and in fact the unit still running sped up to nearly 60 mbps combined rx/tx.

I will now modify some code that I had identified while making this current one.

I'll report back in a week, since this will be a major rewrite.
Reply
#4
Looks like the issue was a damaged internal flash on the Ventana AP.

In Valemount we learned well to always discharge our static before picking up any equipment. In Thailand and in Nanaimo, being coastal with high humidity, it was never an issue, so I got lazy.

I had been noticing a slight "tickle" when touching the gear, but did not clue in, until it totally crapped out. The replacement unit is humming along very nicely, with no issues, as I had previously seen. AND I now touch metal to discharge my static. No more tickle and no more zapping of gear.
Reply
#5
I'm on the right track, for sure. After just a bit of rewriting, I have seen the "typical" running errors drop to near zero, AND throughput has gone from 50 mbps to a wee bit over 70 mbps.

And I'm not done yet.

So, the firmware I will be able to release next week will be complete with ##, 5&10 MHz channels and sync, as well as everything else.

So far this is looking very good and all my hard work is paying off.
Reply
#6
lonnie Wrote:So, the firmware I will be able to release next week will be complete with ##, 5&10 MHz channels and sync, as well as everything else.
What is missing currently in 4.7.1.0-9175?
Reply
#7
WAR1B Access Point, 2.4 Ghz, 25 clients - all Star-OS (mix of WAR1B & WAR1A-SIAM 'G' & WAR1A-SIAM 'N' clients) Applied 4.8.1.0-9175 to all clients and to the AP, reboot and 6 minutes later just 19 clients associated.

PS. 11 minutes later, 22 clients now associated. This was a 10:00 PM CST, so we will watch for AP Stall issue and report.

PS. 20 minutes later, still only 22 clients associated. I think that all the missing clients are all WAR1B's which were upgraded to 4.8.1.0-9175
Reply
#8
It is very complete and I believe all features are working again.

I have a new 9190 release that is in test. It has some improvements in the 5&10 MHz area and also has site survey working. I am not posting it quite yet as I want to do some more testing. Mostly, I would have to remove a whole lot of debug stuff, so when it is deemed solid I will clean it up and post it.

Thanks for testing this.
Reply
#9
Well, I have a whole bunch of truck rolls to do. A bunch of the WAR1B clients that I upgraded have disappeared (not associated) overnight.

A few of them have re-associated with a power cycle
A few of them we can ping but not pass traffic
A few of them we can start to log into (SSH answers) but we can't get past that screen
A few of them that look associated, trying a 'starutil 1.2.3.4 pass -reboot' gives a 'unable to talk with server'
And a bunch of them are simply not associated overnight.

All reports this morning are WAR1B CPE's that were upgraded to 9175 yesterday.
Reply
#10
That is gut wrenching news.

Can you tell me if the failures were AP or Client or both?
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  9243 release lonnie 0 407 05-21-2018, 09:22 AM
Last Post: lonnie
  Release 4.8.1.0.9201 lonnie 0 442 12-14-2017, 10:20 AM
Last Post: lonnie
  Release 4.8.8848 adding Licensed Frequency support lonnie 14 1,458 03-05-2017, 02:48 PM
Last Post: lonnie
  4.7.1.0.8757 release lonnie 3 940 01-24-2017, 05:28 AM
Last Post: lonnie
  New release 4.7.1.0.8747 lonnie 1 881 01-20-2017, 05:47 AM
Last Post: ninedd
  Christmas Even Release 4.6.1.0.8730 lonnie 29 3,029 01-02-2017, 05:05 AM
Last Post: lonnie
  New release of 4.6 code lonnie 7 3,013 11-09-2016, 10:52 PM
Last Post: lonnie
  New release of very early 4.6 code lonnie 22 5,664 11-03-2016, 09:17 AM
Last Post: Ryan
  Having a problem with the 1.4.x release series? tony 210 34,547 01-07-2011, 07:13 AM
Last Post: DrLove73
  LATEST RELEASE: StarOS v2.01.1-4590 tony 1 3,282 06-25-2004, 09:00 AM
Last Post: lonnie

Forum Jump:


Users browsing this thread: 2 Guest(s)