Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
QinQ over PtP bridge
#1
I got a request for a PtP bridge supporting QinQ with MTU=1518. I was pretty sure I had done this before and thought this was simple, but I might be in over my head.

Thought a simple bridge between two M1515N would be all that is needed, I have sold simple bridges for house-to-house connections and those works out well. Bridge eth1 with wpci1 on each unit. But when I try to change MTU from 1500 to 1518, connection is lost.
I also tried to configure VDS with MTU=1518 and even 1522, without success. This is WAR1b with 4.5.5.3.

I can ping 1518 bytes (and larger) over a standard MTU=1500 bridge, but I guess that is not really sufficient test here? It can't be that easy? How can I get this working, and how do I test (without a vlan and certainly without any QinQ equipment)?


Reply
#2
Pinging 1518 just means it fragmented the ping into two packets, would have to use ping -D to test.

I think the important part of your post here is when you change MTU from 1500 to 1518 you lose connection. You'll need to be able to successfully set the MTU of both the wireless and the ethernet interfaces to 1518 and have it work. That is up to whether or not your version is supporting that.
StarOS Community Wiki: http://staros.tog.net/
Reply
#3
I'm curious to know if you changed the MTU size for both ends and both devices, ie Ethernet and WPI? If, for some reason, the MTU does not get assigned to both devices you will have a mismatch and that is not good.

Make sure to do the remote first or you won't get in after changing the local. Set both interfaces on each unit and then activate without saving. That way a simple power off/on will restore things.
Reply
#4
Thank you, both of you! I did change both devices in both ends, and activated remote first. Lost connection when local unit was activated, was connected as long as only remote was changed.
I will try some more. Planned to use M1515N units, but I can use ALIX if I have to go back to older versions. This was 4.5.5.3. Anyone who know (or have any thoughts) of what versions it might be worth trying? Need 11n, but older version will be OK for this simple link. V3 1.5.17?
Reply
#5
An update: Think I found a solution, it seems to work with ALIX and v.4.0.13.1. I am able to set MTU = 1522 and link still works over the bridge.

I also read about ping-testing with values 28 lower than actual, so I tried to ping with 1494 (1522 - 28 ) without result. But I do get positive result with 1490, so that should be 1490 + 28 = 1518 in total size, right? This should be enough for me, but I do not understand why it doesn't work with 1494 (1522)? All interfaces involved is set to 1522, including my win7 PC ethernet.
Reply
#6
You are correct, ping -D -s 1472 is the highest you can go with MTU 1500. If you got a ping -D -s 1490 to work, you've got 1518 passing. I guess the question is did the TUI translate your MTU from 1522 to 1518 for some reason when it applied it under the hood or something. But, no matter, you got what you were looking for.
StarOS Community Wiki: http://staros.tog.net/
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Full Duplex Bridge config question David L. Vrablic 3 2,108 09-18-2010, 02:35 PM
Last Post: tony
  Change of ISP made bad throughput over wireless bridge timotei 7 2,620 02-13-2010, 09:47 PM
Last Post: Kevin Gerrard
  Bridge version mickeym 8 2,249 08-13-2009, 09:04 AM
Last Post: Ick
  CPE client bridge V3 bobbyc 1 1,373 08-06-2009, 12:11 PM
Last Post: lonnie
  1.4.17r cpe as a bridge Kevin Gerrard 31 6,750 05-15-2009, 10:34 AM
Last Post: Kevin Gerrard
  ospf over a bridge truxton 5 2,245 12-31-2008, 10:33 PM
Last Post: lonnie
  VDS Bridge gaf@bluerivernet.com 3 1,744 02-06-2008, 05:23 AM
Last Post: gaf@bluerivernet.com
  Full Duplex Bridge Beebe 8 3,464 01-18-2008, 11:16 AM
Last Post: Beebe
  Nat vs bridge pros/cons markzalot 72 27,496 05-05-2007, 01:18 PM
Last Post: lonnie
  VDS bridge interface palmczak 0 953 11-08-2006, 11:56 AM
Last Post: palmczak

Forum Jump:


Users browsing this thread: 1 Guest(s)