Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OpenWrt for new hardware
#21
(02-25-2020, 06:13 PM)TalStar Wrote: Seems I can get the new to as AP's to each other and other devices in band, however once you move to a "world" frequency it stops broadcasting and are not see by each other or licensed War1b units. This seems to affect both the SB-M1214N and 1205N units. They will however connect to the other Star-OS equipment running on a licensed/world frequency without much issue.


Is there any way I can login to a unit?  Public IP or Remote Desktop to a system in the network?

My test is a 1205 connecting to a bunch of Star and Openwrt clients.


Attached Files Thumbnail(s)
       
Reply
#22
oh forgot to mention that the (WAN/LAN) ports are mixed up vrs the label on the SB-M1214N

I'll double check my settings vrs what you got here maybe I missed something. Although I found it weird that it worked in band then changed to out of band it stopped.

If not I'll set RDP and some gear to for you to test with
Reply
#23
(02-26-2020, 09:50 PM)TalStar Wrote: oh forgot to mention that the (WAN/LAN) ports are mixed up vrs the label on the SB-M1214N

I'll double check my settings vrs what you got here maybe I missed something. Although I found it weird that it worked in band then changed to out of band it stopped.

If not I'll set RDP and some gear to for you to test with

Thanks.  I would like to either help you or see what is wrong and then fix it.
Reply
#24
Some things to check. Openwrt is catering to the home user who has no use for routing, so the Gui tries to bridge everything. You can remove a bridge and it "might" get added back.

So go to the Interfaces and edit any devices that have br- in front of the name. This is changed in the Physical Setting tab.

Go though all firewall settings, removing any Rejects, masquerading, etc. You want something that will talk to anything. Of course, if you need to filter something, you can always add filters back in. I prefer to start from a clean setup and make it all works, then I add things. If it breaks I know it "did" work before
Reply
#25
Any news to report? I am willing to help you get going.
Reply
#26
sorry I've gotten distracted with a few other projects over the last bit. The LAN/WAN on the M1214N units is just a port swap (WAN is LAN and LAN is WAN in factory default configuration.) 

As for wireless looks like this is the error in the log..


Fri Feb 14 00:05:28 2020 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Fri Feb 14 00:05:28 2020 kern.info kernel: [  31.727622] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Fri Feb 14 00:05:28 2020 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Fri Feb 14 00:05:28 2020 daemon.warn hostapd: wlan0: IEEE 802.11 Configured channel (22) not found from the channel list of current mode (1) IEEE 802.11g
Fri Feb 14 00:05:28 2020 daemon.warn hostapd: wlan0: IEEE 802.11 Hardware does not support configured channel
Fri Feb 14 00:05:28 2020 daemon.err hostapd: Could not select hw_mode and channel. (-3)
Fri Feb 14 00:05:28 2020 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->DISABLED
Fri Feb 14 00:05:28 2020 daemon.notice hostapd: wlan0: AP-DISABLED
Fri Feb 14 00:05:28 2020 daemon.err hostapd: wlan0: Unable to setup interface.
Fri Feb 14 00:05:29 2020 daemon.notice hostapd: wlan0: interface state DISABLED->DISABLED
Fri Feb 14 00:05:29 2020 daemon.notice hostapd: wlan0: AP-DISABLED
Fri Feb 14 00:05:29 2020 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Fri Feb 14 00:05:29 2020 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Fri Feb 14 00:05:29 2020 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Fri Feb 14 00:05:29 2020 daemon.notice netifd: radio0 (1270): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory
Fri Feb 14 00:05:29 2020 daemon.notice netifd: radio0 (1270): WARNING (wireless_add_process): executable path /usr/sbin/hostapd does not match process  path (/proc/exe)
Fri Feb 14 00:05:29 2020 daemon.notice netifd: radio0 (1270): Command failed: Invalid argument
Fri Feb 14 00:05:29 2020 daemon.notice netifd: radio0 (1270): Device setup failed: HOSTAPD_START_FAILED
Reply
#27
OK, thanks.

I'll spin another firmware that has the start of starutil installed.  It is work in progress so just ignore it for now.

Also, there will be separate firmware for the 1205 and 1214.

Can you use putty or ssh to login to the test unit?  The type
iw list

and send me clip of the channel list.
Reply
#28
OK, I have uploaded 2 new firmware images, one for 1205 and one for 1214.
Reply
#29
This one is looking a lot better for the 1205! Not have much luck getting clients to connect at 40Mhz yet mind you. I'll do more testing and report back.
Reply
#30
(03-05-2020, 09:08 PM)TalStar Wrote: This one is looking a lot better for the 1205! Not have much luck getting clients to connect at 40Mhz yet mind you. I'll do more testing and report back.


I'll check the code.  There are many places that limit the bandwidth and the default might be 20 MHz.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)